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Training materials: Step by step GIS Training for 
Ecosystem Accounting – focusing on blue carbon 
ecosystems
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Purpose

This guide and the data contained therein is for training purposes only. 

This guide will enable practitioners that are new to Ocean Accounts to compile extent accounts from 
data extracted and manipulated from open access sources. The step-by-step exercise focuses on 
mangroves and aligns with the System of Environmental Economic Accounting - Ecosystem Accounts 
(SEEA EA). It does not, however, cover land classification or condition and ecosystem service 
accounts.

Prepared by:

 Dr Jordan Gacutan, Global Ocean Accounts Partnership (GOAP) Secretariat

Required Materials:

● QGIS software installed on participants' laptops.
● Access to sample datasets for practical exercises.
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Background
This step-by-step guide enables practitioners to calculate statistics for ecosystems at different 
administrative levels for a country, using blue carbon ecosystems within the Maldives as an example. 

● Activity 1 – provides methods for rapid statistics to calculate the stocks of seagrass across 
multiple years. 

● Activity 2 – Works step by step to get data from the QGIS programme into excel, which makes it a 
more shareable format.

For further reading and conceptual support, practitioners are encouraged to refer to the SEEA website 
and Ocean Accounting Technical Guidance.

Case study: Maldives

The Maldives is an archipelagic state located in the Indian Ocean, renowned for its clear waters, coral 
reefs, and abundant marine biodiversity. It contains over 1,200 islands, grouped into 26 atolls, which 
are organized into 19 administrative regions and an additional region encompassing the capital city, 
Malé. Each atoll administration is responsible for managing resources, implementing environmental 
conservation efforts, and overseeing development activities within its jurisdiction. 

The country's geography and climate make it an ideal habitat for a variety of marine ecosystems, 
including extensive seagrass meadows and coral reefs, which support a myriad of fish, crustacean, 
and mollusc species. These ecosystems play a vital role in the Maldivian economy, including the 
sectors of tourism and fisheries. Balancing conservation and development require an understanding 
of ecosystems and their services, to carefully weigh trade-offs in the context of changing 
environments due to climate change. 

Mangroves

Mangroves are complex intertidal ecosystems comprised of salt-tolerant trees and shrubs that flourish 
in sheltered coastal areas. These ecosystems serve as breeding grounds and nurseries for 
commercially important species (e.g., fish, crustaceans, and shellfish). They act as natural barriers, 
protecting shorelines from erosion and storm surges, while simultaneously filtering pollutants and 
sediments from land-based runoff, ensuring the health of adjacent seagrass and coral reefs. 
Furthermore, mangroves contribute significantly to the local economy by providing resources such as 
timber, and traditional medicinal plants. 

Seagrass

Seagrass Meadows within the Maldives are underwater ecosystems characterized by flowering plants 
that form dense underwater beds in shallow, clear waters. These habitats support a diverse array of 
marine life, including endangered species like sea turtles, by providing food and shelter. At least 6 
distinct species of seagrass can be found in the Maldives. Seagrass beds play a critical role in coastal 
protection, mitigating erosion by stabilizing sediments with their root systems. They also act as carbon 
sinks, absorbing carbon dioxide from the atmosphere and ocean, thus helping to mitigate climate 
change. In addition, these meadows enhance water quality by filtering pollutants and provide 
significant economic benefits to local communities as another nursery for fisheries and attract species 
that positively impact tourism.
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Data inventory

Table 1. Data inventory for the exercise

Data type Data name Description Source

Activity 1: Rapid seagrass statistics for Laamu Atoll

Administrative 
areas

Laamu_adm3_43N Administrative boundaries at 
the sub-atoll level, projected 
to UTM zone 43N

Maldives - Subnational 
Administrative Boundaries: 
https://data.humdata.org/dataset/co
d-ab-mdv

Collected by UNICEF, provided by 
Government of the Maldives

Seagrass extent 
shapefiles 

Sg_17, 

SG_20

Seagrass extent generated 
using satellite data (SPOT 
6/7)

Generated using GIS by GOAP 
Secretariat

Satellite data All_2020 Satellite data of Laamu Atoll Generated from SPOT (1.5 m) data. 
Related open access data could be 
downloaded from Copernicus Open 
Access Hub (Sentinel 2, 10 m).
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Getting started
Please get acquainted with QGIS before proceeding. There are materials on the website, which can 
be accessed using this link. We will be working off QGIS version 3.34.

Launch QGIS

Open GIS using the desktop symbol or menu bar. You should be presented with the following:

Figure 1. QGIS Graphical User Interface, showing (1) menu bar, (2) toolbars, (3) panels, (4) map view 
and (5) status bar. Adapted from the QGIS manual (3.28).

Make sure you save the QGIS file, named after the activity (e.g., “MDV_blue_carbon”) 

Practical data for activities
All the sample data for the activities will be stored in a folder, with the link to access below:

Activity Data Download
Please create a new folder for the activities (e.g., “Maldives Blue Carbon”).

1. Ensure that the data has been unzipped and placed in the folder together with the QGIS 
project file (.qgs)

2. Ensure that the file names match those in this guide.
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Activity 1: Seagrass statistics for Laamu Atoll
Objective: Calculate the area of seagrass for a hypothetical area, using Laamu Atoll as a case study.

Context: Imagine you have been requested to compile an inventory (in km2) of the seagrass within 
200 m of each island on Laamu Atoll. You must create an area and analyze the seagrass near each 
island.

Note that you only need to analyse the year 2020.

Workflow

Before starting: Set map Coordinate Reference System (CRS).

● Click on the "Project" menu and select "Properties."
● In the Project Properties dialog box, select the "CRS" tab.
● In the "Filter" section, find the correct CRS (for us it is WGS 84 / UTM Zone 43N). Use the 

filter function to find the correct CRS and click “OK”.

 

Step 1: Add data (Shapefiles) to the Map

You can either drag or drop the shapefile file (extension .shp) into QGIS from the Browser to the map 
section or do the following:

1. Click on the "Layer" menu and select "Add Layer" > "Add Vector Layer."
2. Navigate to the folder containing the shapefiles you want to add.
3. Select the shapefile(s) you want to add and click "Open."
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4. The shapefile(s) will be added to the map and displayed in the Layers panel.

Add the following shapefiles and ensure they are in the table of contents:

● MDV_ADM_43N (Administrative boundary), 
● SG_17_43N – estimated seagrass cover for 2017,
● SG_20 – estimated seagrass cover for 2020.

*When loading shapefile data, please select the file with extension “.shp”. When prompted on options 
– just use defaults.
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Step 2: Check the Coordinate System, project (if needed)

All shapefiles must have the same coordinate reference system (CRS) for analysis. To calculate area 
in m2, a projected CRS must be used. For Maldives, we are using WGS84 / UTM 43N.

Double-click on the layer to open Properties > Select "Source" tab. The CRS of the layer will be 
displayed in the "CRS" field.

Using an example of GMW_WSM_20_WGS – we can see that CRS is WGS 84, not WGS 84 / UTM 
zone 43N! Do not change the CRS in properties. We need to reproject this layer.

 

If not the desired CRS, save a projected version of the file. Be careful not to overwrite your original 
data. 

Close dialogue box. 

Basic steps below, see following page for more detailed instructions.

1. Click on your layer and select “Vector” > “Data Management Tools” > "Reproject layer."
2. The input layer is the target to reproject.
3. Select the "Target CRS" from the list of CRSs.
4. Please save your file (using the 3 dots, purple rectangle). Make sure that the layer is clearly 

renamed (e.g., Output for “SG_20” could be named “SG_20_43N”) and are saved as 
shapefiles (.shp).

5. Click on “Run”.

Check if this is needed for all layers in Activity 1.
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Step 3: Buffer islands

We need to produce a polygon that measures all the seagrass within 200 m of each island. Using 
MDV_ADM_43N (all islands in Laamu), we will “buffer” each polygon, extending each shape by 200 
m.

The steps to buffer are below.

1. Click “Vector” > “Geoprocessing Tools” > "Buffer…"
2. The input layer is the target to buffer.
3. Set “Distance” to 200 m
4. Save your layer, (using the 3 dots, purple rectangle)
5. Click on “Run”.

Make sure that the layer is clearly renamed (e.g., Output could be named “Laamu_Buffer_200”) and 
saved as shapefiles (.shp).
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Step 4: Calculate Intersected Areas

We will now calculate the area of seagrass by comparing (i) the 200 m, with (ii) the seagrass vector 
(e.g., SG_17_43N)

Open the "Intersection" tool (“Vector” > “Geoprocessing Tools”). This tool will create a new shapefile 
with polygons that represent the intersection of the two input shapefiles.

Figure 2. Example of an intersection under the vector overlay tools. Adapted from QGIS guide 
(27.1.19.5)

Enter the following into the dialogue box:

● Input Features: Select the projected layer representing the buffered zones per island 
(Laamu_buffer_200).

● Overlay Features: Select the layer representing the areas of interest (seagrass – 
SG_20_43N).

● Under “intersection”, save to file (purple box - suggested name “SG_20_int”)
● Click “Run” when ready.
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Output of Step 3, using Maavah as an example.

Light green areas show what is measured by the intersected area, while dark green show areas 
outside the buffer zone.
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Step 4.5: Fix geometries

For QGIS, geometries of your files need to comply with Open GIS, specifically:

● Lines are valid if they don't pass an inner vertex twice.
● Polygons are valid if their linear components are simple and none of their rings cross.

When using QGIS, sometimes your files will require their geometries to be fixed, especially if they 
have been created in ArcGIS (.shp) or Google Earth (.kmz files), which do not always comply with the 
QGIS standards for valid geometries.

We will need to fix your new intersected file, SG_20_int, using fix geometries. Search and locate fix 
geometries in your processing toolbox. If you cannot see your toolbox, follow the below steps:

● View > Panels> Processing Toolbox.
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Step 5: Calculate Area

Right click on the layer from Step 3 > "Open Attribute Table" of the new shapefile.

● Toggle “Edit mode” and “Add field” named “Area_sqm”. Set type to Decimal.

● Turn off “Edit mode” and open the “Field Calculator” (Red).
● Options:

o Update existing field – Area_sqm, 
o Expression - area($geometry)

Make sure that there are no features selected or uncheck the box for selected features.

You should now have a table that has area in square meters.
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Activity 2: QGIS to Excel
Converting data from QGIS attribute table to Excel formats allows a wide range of stakeholders with 
access to spatial data. Excel allows users who may not have GIS expertise but require access to the 
data for tasks such as statistical analysis, or reporting.

Workflow

Step 1: Copy and paste the table into Excel

To open attribute table (Right click > “Open attribute table”) and ensure it’s in table view.

The intersect tool will (1) remove areas that are not found within each island buffer boundary and (2) 
assign each section to a specific buffer. Note the field of view shows Dhabidhoo.

Select all rows (Ctrl + A) and right click to copy. Paste into excel.
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Delete columns (wkt_geom and CLASS_Name - marked in red). Keep ADM3_EN and area_sqm (in 
green) 

● ADM3_EN- Field with name per island
● Area_sqm - Area of seagrass in square meters

Step 2: Convert units

Create a new column called “area_km2”. We will convert the area to square kilometres (km2) using 
the following relationship (1 m2 = 0.000001 km2). Use the equation = [cell with area_sqm] * 
0.000001.

Then, you can drag the equation to all the relevant cells in the column by double clicking the green 
square of the cell. Alternatively, you can copy and paste the equation, highlighting all the relevant cells 
in the column. 
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Step 3: Set up your pivot table

A pivot table is a tool to summarize data, enabling users to automatically sort, count, and total or 
average the data stored in one table and present it in a second table. This interactive process allows 
users to rearrange (or "pivot") the columns and rows of data to view it from different perspectives, 
offering a customizable report from a larger data set. We will drag and drop fields into different axes of 
the pivot table, to explore the data without altering the original data. 

1. Click anywhere in your data and format the rows as a table.

2. Produce a pivot table next to your data. 

3. Select existing worksheet and click a cell near your data.
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Step 4: Adding values to the pivot table

You will now have an empty pivot table, like below. Add the following data to the rows and columns of the pivot 
table. Experiment with the combinations – how do they change the data that is presented?

Step 5: Calculate statistics

You will have a table that shows the area (in m2 and km2) for all islands. Fill in the table on the 
following page.
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Fill the table below:

Table 2. Estimated mangrove extent per island area, buffered by 200 m

Island

Area (m2) Area (km2) Percentage 
change 

(includes 
cloud / error)2017 2020 2017 2020

Dhabidhoo 571202.77 0.57

Fonadhoo 1210572.69 1.21

Gaadhoo 890431.17 0.89

Gan 518784.74 0.52

Hithadhoo 524001.71 0.52

Isdhoo 434165.26 0.43

Kalhaidhoo 124660.88 0.12

Kunahandho
o 232868.21 0.23

Maabaidhoo 317731.38 0.32

Maamendhoo 26656.43 0.03

Maavah 681691.35 0.68

Mundhoo 351278.25 0.35

Grand Total
12826743.3

5 12.82
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General guidance
Data sources

Data for ocean accounts (mangroves and beyond) may come from a variety of sources. Accounting 
activities should carefully consider whether national or international datasets should be used to 
achieve robust and accurate accounts.

National and international datasets both offer valuable resources for compiling ecosystem accounts, 
but the choice between them depends on several factors. National datasets could provide detailed 
information specific to a particular country's ecosystems and economic activities. This granularity can 
be crucial for understanding local environmental challenges and informing policy decisions. However, 
national data may not be standardized or comparable across different areas (and adjacent countries) 
and may not contain sufficient timeseries.

International datasets, on the other hand, offer consistent methodologies and formats that may be 
maintained over time (e.g., Landsat satellite imagery). This can be helpful for identifying trends and 
informing sustainable development goals, especially if national data is limited. The data, however, 
may not be at an appropriate resolution to resolve important local variations. It is also important to 
note that there can be inconsistencies in national statistics generated from international datasets. The 
choice of data sources should be determined through consultation and consensus among key 
stakeholders and end-users including, but not limited to, the Ministry of Environment, Geographic 
Information Systems (GIS) practitioners, and national statistical office.

Processing satellite data vs. existing polygons

Note that data from these sources may be unclassified remote sensing images or already classified 
into discrete categories. If data is the raw remote sensing image, usually a raster, the data must be 
classified into meaningful categories (e.g., water, forest, mangrove). This step may not be applicable if 
it has already been conducted. These classified datasets might originate from previous satellite image 
classifications, field surveys, or other sources. Note, however, that the classifications may differ to 
your needs and should be carefully assessed before use. 

Key considerations for mangroves

● Data Availability: The availability and quality of mangrove data vary considerably across the 
Pacific. Some countries might have detailed mapping, while others might have limited or 
outdated information.

● Data Format: Data formats and accessibility can vary across sources. Carefully note the 
different file formats. Project and extract relevant information when needed.

● Ground truthing: Satellite imagery and remote sensing data are often used for mapping 
global and international datasets. These datasets, however, may have been trained using 
different conditions than the local context. Ground truthing is needed to determine the 
accuracy of these datasets. 

Potential sources for mangrove data

The European Space Agency's (ESA) Copernicus program provides unprecedented access to the 
Sentinel satellite constellation. Among these, Sentinel-2 provides high-resolution optical imagery and 
processed data on land cover, vegetation, and environmental dynamics. The platform contains 13 
sensors, with a spatial resolution varying from 10 m to 60 m. The combination of these sensors 
provides indices that assist in identifying mangrove extent and health. Data from the satellite could be 
either the raw raster image or processed into classes.

Time series / Accounting years
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Timeseries data is crucial for environmental economic accounting because it enables analyses that 
link trends to potential drivers. Specifically, timeseries assist in understand change through identifying 
trends and breakpoints:

● Trends: Patterns in the data that could show increase or decrease through time. For 
example, total and rates of loss in habitat. 

● Breakpoints: Certain years might signal significant changes in the system. An introduction of 
a new environmental tax, a major natural disaster, or a shift in government policy can all have 
noticeable impacts.

There is no single "correct" timeframe or timeseries for environmental economic accounting. Choosing 
the right years depends on the specific use cases and questions, data availability, and the desired 
level of detail. By carefully considering these factors and the importance of timeseries data, robust 
and informative accounts could be compiled, which could inform solutions towards environmental 
challenges. For example:

● If the question is measuring change over time, the regular production of accounts over fixed 
time periods (e.g., every two years) would be beneficial, 

● If the accounts will investigate immediate changes due to an event, an appoint focusing on 
breakpoints may be more appropriate. 

Trade-offs are often made between “breadth” and “depth” of data. Longer Timeseries offer a wider 
perspective on environmental trends and changes, while shorter timeseries could assist in 
understanding specific issues or events. For example, accounts could isolate the effects of specific 
policies, and capture more nuanced dynamics. Longer timeseries may have data gaps or less 
granularity, while shorter ones may not capture long-term trends or miss crucial turning points.
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Annex: Answers
Activity 1

Island 2017 (km2) 2020 (km2)
Percentage change 

(includes cloud / 
error)

Dhabidhoo 0.57 0.41 27.47%

Fonadhoo 1.21 1.13 6.53%

Gaadhoo 0.89 0.85 4.71%

Gan 0.52 0.47 10.27%

Hithadhoo 0.52 0.35 33.46%

Isdhoo 0.43 0.92 -112.10%

Kalhaidhoo 0.12 0.09 24.88%

Kunahandhoo 0.23 0.54 -129.98%

Maabaidhoo 0.32 0.19 40.58%

Maamendhoo 0.03 0.03 -27.52%

Maavah 0.68 0.73 -6.68%

Mundhoo 0.35 0.37 -6.33%

Grand Total 12.82 12.39
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